- NetBSD Manual Pages
LOCATE.CONF(5) NetBSD File Formats Manual LOCATE.CONF(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
locate.conf -- locate database configuration file
The locate.conf file specifies the behavior of locate.updatedb(8), which
creates the locate(1) database.
The locate.conf file contains a list of newline separated records, each
of which is composed of a keyword and arguments, which are separated by
white space. Arguments with embedded shell metacharacters must be quoted
in sh(1) style. Lines beginning with ``#'' are treated as comments and
ignored. However, a ``#'' in the middle of a line does not start a com-
The configuration options are as follows:
ignore pattern ...
Ignore files or directories. When building the database, do not
descend into files or directories which match one of the speci-
fied patterns. The matched files or directories are not stored
to the database.
Default: Not specified.
ignorecontents pattern ...
Ignore contents of directories. When building the database, do
not descend into files or directories which match one of the
specified patterns. The matched files or directories themselves
are stored to the database.
Default: Not specified.
ignorefs type ...
Ignore file system by type, adding type to the default list.
When building the database, do not descend into file systems
which are of the specified type. The mount points are not stored
to the database. If a ``!'' is prepended to type, the meaning is
negated, that is, ignore file systems which do not have the type.
As a special case, if ``none'' is specified for type, the
ignorefs list is cleared and all file systems are traversed.
type is used as an argument to find(1) -fstype. The sysctl(8)
command can be used to find out the types of file systems that
are available on the system:
Default: !local cd9660 fdesc kernfs procfs
searchpath directory ...
Specify base directories to be put in the database.
Specify the working directory of locate.updatedb, in which a tem-
porary file is placed. The temporary file is a list of all
files, and you should specify a directory that has enough space
to hold it.
Refer to find(1) for the details of pattern (see -path expression) and
type (see -fstype expression).
/etc/locate.conf The file locate.conf resides in /etc.
find(1), locate(1), locate.updatedb(8), sysctl(8)
The locate.conf file format first appeared in NetBSD 2.0.
NetBSD 7.1.2 July 10, 2011 NetBSD 7.1.2