- NetBSD Manual Pages
ALTQ(4) NetBSD Kernel Interfaces Manual ALTQ(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
altq -- alternate queuing framework
The altq framework provides several disciplines for queuing outgoing net-
work packets. While traffic shaping is perhaps the most prominent exam-
ple, altq provides also other measures related to QoS. The framework has
been integrated to the pf(4) packet filter since NetBSD 4.0.
At the implementation level altq modifies the interface packet queues.
Therefore the driver modifications described in altq(9) are required in
order to use a certain network card with altq.
pf(4), altq.conf(5), altqd(8), altq(9)
Kenjiro Cho, Fitting theory into reality in the ALTQ case,
http://www.sonycsl.co.jp/~kjc/papers/fittingtheory.pdf, March, 2004, Asia
NetBSD 7.1.2 June 22, 2011 NetBSD 7.1.2