- NetBSD Manual Pages
ACPIDUMP(8) NetBSD System Manager's Manual ACPIDUMP(8)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
acpidump -- dump ACPI tables and ASL
acpidump [-cdhstv] [-f dsdt_input] [-o dsdt_output]
The acpidump utility analyzes ACPI tables in physical memory and can dump
them to a file. In addition, acpidump can call iasl(8) to disassemble
AML (ACPI Machine Language) found in these tables and dump them as ASL
(ACPI Source Language) to stdout.
ACPI tables have an essential data block (the DSDT, Differentiated System
Description Table) that includes information used on the kernel side such
as detailed information about PnP hardware, procedures for controlling
power management support, and so on. The acpidump utility can extract
the DSDT data block from physical memory and store it into an output file
and optionally also disassemble it. If any Secondary System Description
Table (SSDT) entries exist, they will also be included in the output file
When acpidump is invoked without the -f option, it will read ACPI tables
from physical memory via /dev/mem. First it searches for the RSDP (Root
System Description Pointer), which has the signature "RSD PTR ", and then
gets the RSDT (Root System Description Table), which includes a list of
pointers to physical memory addresses for other tables. The RSDT itself
and all other tables linked from RSDT are generically called SDTs (System
Description Tables) and their header has a common format which consists
of items such as Signature, Length, Revision, Checksum, OEMID, OEM Table
ID, OEM Revision, Creator ID and Creator Revision. When invoked with the
-t flag, the acpidump utility dumps contents of the following tables:
The RSDT contains a pointer to the physical memory address of the FACP
(Fixed ACPI Description Table). The FACP defines static system informa-
tion about power management support (ACPI Hardware Register Implementa-
tion) such as interrupt mode (INT_MODEL), SCI interrupt number, SMI com-
mand port (SMI_CMD) and the location of ACPI registers. The FACP also
has a pointer to a physical memory address for the DSDT. While the other
tables are fixed format, the DSDT consists of free-formatted AML data.
The following options are supported by acpidump:
-c Dump unknown table data as characters instead of hex.
-d Disassemble the DSDT into ASL using iasl(8) and print the results
Load the DSDT from the specified file instead of physical memory.
Since only the DSDT is stored in the file, the -t flag may not be
used with this option.
-h Displays usage and exit.
Store the DSDT data block from physical memory into the specified
-s Skip tables with bad checksums.
-t Dump the contents of the various fixed tables listed above.
-v Enable verbose messages.
If a developer requests a copy of your ASL, please use the following com-
mand to dump all tables and compress the result.
# acpidump -dt | gzip -c9 > my_computer.asl.gz
This example dumps the DSDT from physical memory to foo.dsdt. It also
prints the contents of various system tables and disassembles the AML
contained in the DSDT to stdout, redirecting the output to foo.asl.
# acpidump -t -d -o foo.dsdt > foo.asl
This example reads a DSDT file and disassembles it to stdout. Verbose
messages are enabled.
# acpidump -v -d -f foo.dsdt
acpi(4), amldb(8), iasl(8)
The acpidump utility first appeared in FreeBSD 5.0 and was rewritten to
use iasl(8) for FreeBSD 5.2.
Doug Rabson <dfr@FreeBSD.org>
Mitsuru IWASAKI <iwasaki@FreeBSD.org>
Yasuo YOKOYAMA <yokoyama@jp.FreeBSD.org>
Nate Lawson <njl@FreeBSD.org>
Some contributions made by Chitoshi Ohsawa <email@example.com>,
Takayasu IWANASHI <firstname.lastname@example.org>, Yoshihiko
SARUMARU <email@example.com>, Hiroki Sato <hrs@FreeBSD.org>, Michael
Lucas <firstname.lastname@example.org> and Michael Smith
The current implementation does not dump some miscellaneous tables.
NetBSD 7.1.2 February 17, 2011 NetBSD 7.1.2