- NetBSD Manual Pages
ZDUMP(8) NetBSD System Manager's Manual ZDUMP(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
zdump -- time zone dumper
zdump [--version] [-v] [-V] [-c [loyear,]highyear] [zonename ...]
zdump -t [lotime,]hightime [zonename ...]
zdump prints the current time in each zonename named on the command line.
These options are available:
--version Output version information and exit.
-v For each zonename on the command line, print the time at the
lowest possible time value, the time one day after the lowest
possible time value, the times both one second before and
exactly at each detected time discontinuity, the time at one
day less than the highest possible time value, and the time at
the highest possible time value. Each line is followed by
is positive, zero, or negative depending on whether the given
time is daylight saving time, standard time, or an unknown
time type, respectively. Each line is also followed by
if the given local time is known to be seconds east of Green-
Cut off verbose output at the given year(s). Cutoff times are
computed using the proleptic Gregorian calendar with year 0
and with Universal Time (UT) ignoring leap seconds. The lower
bound is exclusive and the upper is inclusive; for example, a
of 1970 excludes a transition occurring at 1970-01-01 00:00:00
UTC but a
of 1970 includes the transition. The default cutoff is
Cut off verbose output at the given time(s), given in decimal
seconds since 1970-01-01 00:00:00 Coordinated Universal Time
(UTC). The zonename determines whether the count includes
leap seconds. As with -c, the cutoff's lower bound is exclu-
sive and its upper bound is inclusive.
-V Like -v, except omit the times relative to the extreme time
values. This generates output that is easier to compare to
that of implementations with different time representations.
Time discontinuities are found by sampling the results returned by local-
time at twelve-hour intervals. This works in all real-world cases; one
can construct artificial time zones for which this fails.
In the output, ``UT'' denotes the value returned by gmtime(3), which uses
UTC for modern time stamps and some other UT flavor for time stamps that
predate the introduction of UTC. No attempt is currently made to have
the output use ``UTC'' for newer and ``UT'' for older time stamps, partly
because the exact date of the introduction of UTC is problematic.
ctime(3), tzfile(5), zic(8)
NetBSD 7.0 October 23, 2014 NetBSD 7.0