- NetBSD Manual Pages
WE(4) NetBSD Kernel Interfaces Manual WE(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
we -- Western Digital/SMC WD80x3, SMC Elite Ultra, and SMC EtherEZ Ether-
net cards device driver
we0 at isa? port 0x280 iomem 0xd0000 irq 9
we1 at isa? port 0x300 iomem 0xcc000 irq 10
we* at mca? slot ?
we0 at vme0 irq 4 # SMC Elite Ultra with SMC_TT VME-ISA bridge
The we device driver supports Western Digital/SMC WD80x3, SMC Elite
Ultra, and SMC EtherEZ Ethernet cards.
For some clone boards the driver is not able to recognize 16bit or 8bit
interfaces correctly. Since this makes a huge difference (see diagnostic
section below) you can override this by specifying flags value in the
we2 at isa? port 0x300 iomem 0xe0000 irq 15 flags 4
The values to add together for flags are:
2 force adapter to be treated as 8bit, even if it probes as a 16bit
interface. Improper use of this flag will make the driver fail or send
invalid Ethernet packets.
4 force adapter to be treated as 16bit, even if it probes as a 8bit
interface. For example the COMPEX ENT/U boards identify as WD8003 com-
patibles, but are in fact 16bit cards. Using this flag on a board that
really is a 8bit board will result in bogus packets being sent.
8 disable the use of double transmit buffers to save space in the on-
board RAM for more receive buffers.
Note that all supported MCA cards are 16bit, and the SMC_TT VME-ISA
bridge interface for atari supports only SMC Elite Ultra.
The ability to select media from software is dependent on the particular
model of WD/SMC card. The following models support only manual configu-
ration: WD8003S, WD8003E, and WD8013EBT.
Other WD/SMC 80x3 interfaces support two types of media on a single card.
All support the AUI media type. The other media is either BNC or UTP
behind a transceiver. Software cannot differentiate between BNC and UTP
cards. On some models, the AUI port is always active.
The SMC Elite Ultra and SMC EtherEZ interfaces support three media a sin-
gle card: AUI, BNC, and UTP. If the transceiver is active, the BNC media
is selected. Otherwise, the AUI and UTP ports are both active.
To enable the AUI media, select the 10base5 or aui media type with
ifconfig(8)'s media directive. To select the other media (transceiver),
select the 10base2 or bnc media type.
we0: overriding IRQ <n> to <m> The IRQ specified in the kernel configu-
ration file is different from that found in the card's configuration reg-
isters. The value in the kernel configuration file is being overridden
by the one configured into the card.
we0: can't wildcard IRQ on a <model> The IRQ was wildcarded in the ker-
nel configuration file, and the card is a WD8003S, WD8003E, or WD8013EBT,
which do not support software IRQ configuration.
we0: failed to clear shared memory at offset <off> The memory test was
unable to clear the interface's shared memory region. This often indi-
cates that the card is configured at a conflicting iomem address.
we0: warning - receiver ring buffer overrun The DP8390 Ethernet chip
used by this board implements a shared-memory ring-buffer to store incom-
The 16bit boards (8013 series) have 16k of memory as well as fast memory
access speed. Typical memory access speed on these boards is about
4MB/second. These boards generally have no problems keeping up with full
Ethernet speed and the ring-buffer seldom overfills.
However, the 8bit boards (8003) usually have only 8k bytes of shared mem-
ory. This is only enough room for about 4 full-size (1500 byte) packets.
This can sometimes be a problem, especially on the original WD8003E,
because these boards' shared-memory access speed is quite slow; typically
only about 1MB/second. The overhead of this slow memory access, and the
fact that there is only room for 4 full-sized packets means that the
ring-buffer will occasionally overrun. When this happens, the board must
be reset to avoid a lockup problem in early revision 8390's. Resetting
the board causes all of the data in the ring-buffer to be lost, requiring
it to be retransmitted/received, congesting the board further. Because
of this, maximum throughput on these boards is only about 400-600k per
This problem is exasperated by NFS because the 8bit boards lack suffi-
cient memory to support the default 8k byte packets that NFS and other
protocols use as their default. If these cards must be used with NFS,
use the NFS -r and -w options in /etc/fstab to limit NFS's packet size.
4096 byte packets generally work.
ifmedia(4), intro(4), isa(4), mca(4), ifconfig(8)
NetBSD 7.0 March 23, 2010 NetBSD 7.0