- NetBSD Manual Pages
URIO(4) NetBSD Kernel Interfaces Manual URIO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
urio -- USB driver for the Diamond Multimedia Rio500 MP3 player
urio* at uhub?
The urio driver provides support for Rio500 MP3 player from Diamond Mul-
The driver implements minimal support to access the device and requires a
user application for up and downloading music.
/dev/urio0 device node
Using the Rio500 package from sourceforge the command
will download a song over the USB connection into your Rio500.
The urio driver appeared in NetBSD 1.5. This driver is based on a
FreeBSD Rio driver written by Iwasa Kazmi.
NetBSD 7.0 March 6, 2000 NetBSD 7.0