- NetBSD Manual Pages
SYNC(8) NetBSD System Manager's Manual SYNC(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
sync -- force completion of pending disk writes (flush cache)
The sync program can be called to ensure that all disk writes have been
completed before the processor is halted in a way not suitably done by
reboot(8) or halt(8). Generally, it is preferable to use reboot(8) or
halt(8) to shut down the system, as they may perform additional actions
such as resynchronizing the hardware clock and flushing internal caches
before performing a final sync.
The sync program simply invokes the sync(2) system call.
fsync(2), sync(2), halt(8), reboot(8)
A sync command appeared in Version 6 AT&T UNIX.
NetBSD 7.0 May 31, 1993 NetBSD 7.0