- NetBSD Manual Pages
RUMP_SMBFS(8) NetBSD System Manager's Manual RUMP_SMBFS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rump_smbfs -- mount a smbfs share with a userspace server
rump_smbfs [options] share mountpoint
NOTE! This manual page describes features specific to the rump(3) file
server. Please see mount_smbfs(8) for a full description of the avail-
able command line options.
The rump_smbfs utility can be used to mount smbfs file systems. It uses
rump(3) and p2k(3) to facilitate running the file system as a server in
userspace. As opposed to mount_smbfs(8), rump_smbfs does not use file
system code within the kernel and therefore does not require kernel sup-
port except puffs(4). Apart from a minor speed penalty there is no down-
side with respect to in-kernel code.
Even though the rump_smbfs file system client runs within a virtual rump
kernel in userspace, it uses host network services (by means of ``rump
sockin''). This means that regardless of whether using rump_smbfs or
mount_smbfs(8), the same network configurations will be used. Currently,
``sockin'' supports IPv4.
To use rump_smbfs via mount(8), the flags -o rump and -t smbfs should be
given. Similarly, rump_smbfs is used instead of mount_smbfs(8) if
``rump'' is added to the options field of fstab(5).
p2k(3), puffs(3), rump(3), mount_smbfs(8)
The rump_smbfs utility first appeared in NetBSD 6.0.
NetBSD 7.0 November 21, 2010 NetBSD 7.0