cltp(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
CLTP(4)                 NetBSD Kernel Interfaces Manual                CLTP(4)


NAME
cltp -- ISO Connectionless Transport Protocol
SYNOPSIS
#include <sys/socket.h> #include <netiso/iso.h> int socket(AF_ISO, SOCK_DGRAM, 0);
DESCRIPTION
CLTP is a simple, unreliable datagram protocol which is accessed via the SOCK_DGRAM abstraction for the ISO protocol family. CLTP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). CLTP address formats are identical to those used by TP. In particular CLTP provides a service selector in addition to the normal ISO NSAP. Note that the CLTP selector space is separate from the TP selector space (i.e. a CLTP selector may not be ``connected'' to a TP selector). Options at the CLNP network level may be used with CLTP; see clnp(4).
DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been con- nected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRINUSE] when an attempt is made to create a socket with a selec- tor which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a net- work address for which no network interface exists.
SEE ALSO
getsockopt(2), recv(2), send(2), socket(2), clnp(4), intro(4), iso(4) NetBSD 6.0 June 9, 1993 NetBSD 6.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.