- NetBSD Manual Pages
RESOLV.CONF(5) NetBSD File Formats Manual RESOLV.CONF(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
resolv.conf -- resolver configuration file
The resolv.conf file specifies how the resolver(3) routines in the C
library (which provide access to the Internet Domain Name System) should
operate. The resolver configuration file contains information that is
read by the resolver routines the first time they are invoked by a
process. The file is designed to be human readable and contains a list
of keywords with values that provide various types of resolver informa-
On a normally configured system this file should not be necessary. The
only name server to be queried will be on the local machine, the domain
name is determined from the host name, and the domain search path is con-
structed from the domain name.
The different configuration options are:
nameserver IPv4 address (in dot notation) or IPv6 address (in
hex-and-colon notation) of a name server that the resolver
should query. Scoped IPv6 address notation is accepted as
well (see inet6(4) for details). Up to MAXNS (currently 3)
name servers may be listed, one per keyword. If there are
multiple servers, the resolver library queries them in the
order listed. If no nameserver entries are present, the
default is to use the name server on the local machine. (The
algorithm used is to try a name server, and if the query
times out, try the next, until out of name servers, then
repeat trying all the name servers until a maximum number of
retries are made).
domain Local domain name. Most queries for names within this domain
can use short names relative to the local domain. If no
domain entry is present, the domain is determined from the
local host name returned by gethostname(3); the domain part
is taken to be everything after the first `.'. Finally, if
the host name does not contain a domain part, the root domain
lookup This keyword is now ignored: its function has been superseded
by features of nsswitch.conf(5).
search Search list for host-name lookup. The search list is nor-
mally determined from the local domain name; by default, it
begins with the local domain name, then successive parent
domains that have at least two components in their names.
This may be changed by listing the desired domain search path
following the search keyword with spaces or tabs separating
the names. Most resolver queries will be attempted using
each component of the search path in turn until a match is
found. Note that this process may be slow and will generate
a lot of network traffic if the servers for the listed
domains are not local, and that queries will time out if no
server is available for one of the domains.
The search list is currently limited to six domains with a
total of 1024 characters.
sortlist Sortlist allows addresses returned by gethostbyname to be
sorted. A sortlist is specified by IP address netmask pairs.
The netmask is optional and defaults to the natural netmask
of the net. The IP address and optional network pairs are
separated by slashes. Up to 10 pairs may be specified, ie.
sortlist 22.214.171.124/255.255.240.0 126.96.36.199
options Options allows certain internal resolver variables to be mod-
ified. The syntax is:
options option ...
where option is one of the following:
debug enable debugging information, by setting RES_DEBUG
in _res.options (see resolver(3)).
edns0 attach OPT pseudo-RR for ENDS0 extension specified
in RFC 2671, to inform DNS server of our receive
buffer size. The option will allow DNS servers to
take advantage of non-default receive buffer size,
and to send larger replies. DNS query packets
with EDNS0 extension is not compatible with non-
EDNS0 DNS servers. The option must be used only
when all the DNS servers listed in nameserver
lines are able to handle EDNS0 extension.
inet6 enable support for IPv6-only applications, by set-
ting RES_USE_INET6 in _res.options (see
resolver(3)). The option is meaningful with cer-
tain kernel configuration only and use of this
option is discouraged.
insecure1 Do not require IP source address on the reply
packet to be equal to the servers' address.
insecure2 Do not check if the query section of the reply
packet is equal to that of the query packet. For
testing purposes only.
ndots:n sets a threshold for the number of dots which must
appear in a name given to res_query (see
resolver(3)) before an initial absolute query will
be made. The default for n is 1, meaning that if
there are any dots in a name, the name will be
tried first as an absolute name before any search
list elements are appended to it.
The domain and search keywords are mutually exclusive. If more than one
instance of these keywords is present, the last instance will override.
The search keyword of a system's resolv.conf file can be overridden on a
per-process basis by setting the environment variable LOCALDOMAIN to a
space-separated list of search domains.
The options keyword of a system's resolv.conf file can be amended on a
per-process basis by setting the environment variable RES_OPTIONS to a
space-separated list of resolver options as explained above.
The keyword and value must appear on a single line, and the keyword (e.g.
nameserver) must start the line. The value follows the keyword, sepa-
rated by white space.
/etc/resolv.conf The file resolv.conf resides in /etc.
gethostbyname(3), resolver(3), nsswitch.conf(5), hostname(7), named(8)
Name Server Operations Guide for BIND.
The resolv.conf file format appeared in 4.3BSD.
NetBSD 5.1 January 16, 1999 NetBSD 5.1