- NetBSD Manual Pages
RACOON(8) NetBSD System Manager's Manual RACOON(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
racoon -- IKE (ISAKMP/Oakley) key management daemon
racoon [-46BdFLv] [-f configfile] [-l logfile] [-P isakmp-natt-port]
racoon speaks the IKE (ISAKMP/Oakley) key management protocol, to estab-
lish security associations with other hosts. The SPD (Security Policy
Database) in the kernel usually triggers racoon. racoon usually sends
all informational messages, warnings and error messages to syslogd(8)
with the facility LOG_DAEMON and the priority LOG_INFO. Debugging mes-
sages are sent with the priority LOG_DEBUG. You should configure
syslog.conf(5) appropriately to see these messages.
-6 Specify the default address family for the sockets.
-B Install SA(s) from the file which is specified in racoon.conf(5).
-d Increase the debug level. Multiple -d arguments will increase
the debug level even more.
-F Run racoon in the foreground.
Use configfile as the configuration file instead of the default.
-L Include file_name:line_number:function_name in all messages.
Use logfile as the logging file instead of syslogd(8).
Use isakmp-natt-port for NAT-Traversal port-floating. The
default is 4500.
Listen to the ISAKMP key exchange on port isakmp-port instead of
the default port number, 500.
-v This flag causes the packet dump be more verbose, with higher
racoon assumes the presence of the kernel random number device rnd(4) at
The command exits with 0 on success, and non-zero on errors.
/etc/racoon.conf default configuration file.
ipsec(4), racoon.conf(5), syslog.conf(5), setkey(8), syslogd(8)
The racoon command first appeared in the ``YIPS'' Yokogawa IPsec imple-
The use of IKE phase 1 aggressive mode is not recommended, as described
NetBSD 5.1 November 20, 2000 NetBSD 5.1