- NetBSD Manual Pages
AZALIA(4) NetBSD Kernel Interfaces Manual AZALIA(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
azalia -- Generic High Definition Audio device driver
azalia* at pci? dev ? function ?
audio* at audiobus?
The azalia device driver is expected to support any PCI device which is
compliant to the High Definition Audio Specification 1.0. Known sup-
ported controllers are Intel 82801F (ICH6) and Intel 82801G (ICH7).
Known supported codecs are Realtek ALC260, ALC880, ALC882, Analog Devices
AD1981HD, CMedia CMI9880, Sigmatel STAC9221, and STAC9221D.
audio(4), pci(4) http://www.intel.com/standards/hdaudio/
The azalia device driver appeared in NetBSD 3.0.
Non-PCM encodings such as Float32 and AC-3 are not supported.
There is no way to use 20bit or 24bit precision because of a limitation
of the MI audio framework.
NetBSD 5.1 March 15, 2007 NetBSD 5.1