- NetBSD Manual Pages
WEEKLY.CONF(5) NetBSD File Formats Manual WEEKLY.CONF(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
weekly.conf -- weekly maintenance configuration file
The weekly.conf file specifies which of the standard /etc/weekly services
are performed. The /etc/weekly script is run, by default, every Saturday
morning on a NetBSD system.
The variables described below can be set to ``YES'' or ``NO'' in the
/etc/weekly.conf file. The default settings are in the
/etc/defaults/weekly.conf file. (Note that you should never edit
/etc/defaults/weekly.conf directly, as it is often replaced during system
rebuild_locatedb This rebuilds the locate database,
/var/db/locate.database, which must also exist, in
order to be rebuilt.
rebuild_whatisdb This rebuilds the whatis database(s). Note that NetBSD
provides a default whatis.db for the system manual
pages and this may not be needed. (Adjust your
/etc/man.conf as necessary. See man.conf(5) for
/etc/weekly weekly maintenance script
/etc/weekly.conf weekly maintenance configuration
/etc/weekly.local local site additions to /etc/weekly
The weekly.conf file appeared in NetBSD 1.3.
NetBSD 5.0 February 15, 2007 NetBSD 5.0