- NetBSD Manual Pages
VMEM(9) NetBSD Kernel Developer's Manual VMEM(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vmem -- virtual memory allocator
The vmem is a general purpose resource allocator. Despite its name, it
can be used for arbitrary resources other than virtual memory.
This section describes places within the NetBSD source tree where actual
code implementing the vmem subsystem can be found. All pathnames are
relative to /usr/src.
The vmem subsystem is implemented within the file sys/kern/subr_vmem.c.
intro(9), memoryallocators(9), vmem_alloc(9), vmem_create(9),
vmem_destroy(9), vmem_free(9), vmem_xalloc(9), vmem_xfree(9)
Jeff Bonwick and Jonathan Adams, "Magazines and Vmem: Extending the Slab
Allocator to Many CPUs and Arbitrary Resources", 2001 USENIX Annual
Technical Conference, 2001.
This implementation of vmem was written by YAMAMOTO Takashi.
NetBSD 5.0 October 22, 2006 NetBSD 5.0