- NetBSD Manual Pages
PUTTER(9) NetBSD Kernel Developer's Manual PUTTER(9)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
putter -- Pass-to-Userspace Transporter
The putter subsystem is used for request-response handling of userspace
components. It currently provides routines for associating a file
descriptor with a subsystem data structure instance and I/O routines.
Users of the facility must fill out the callbacks in struct putter_ops to
integrate with putter.
Under construction. Interfaces may and will change.
NetBSD 5.0 November 21, 2007 NetBSD 5.0