- NetBSD Manual Pages
MSTOHZ(9) NetBSD Kernel Developer's Manual MSTOHZ(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mstohz -- convert milliseconds to system clock ticks
mstohz can be used to convert time in milliseconds to system clock ticks,
as used by the callout(9) facility, in an integer-overflow safe way.
This function is implemented as a define in the <sys/param.h> header.
Individual ports can have a processor-specific, more efficient version
implemented in their <machine/param.h> header as a define.
The return value is the number of clock ticks for the specified value.
The machine-independent mstohz() function does not make use of expensive
64-bit integer arithmetic, so the result will be rounded down to one sec-
ond if the parameter is larger than 131072 milliseconds.
NetBSD 5.0 April 4, 2002 NetBSD 5.0