- NetBSD Manual Pages
MDSETIMAGE(8) NetBSD System Manager's Manual MDSETIMAGE(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mdsetimage -- set kernel RAM disk image
mdsetimage [-svx] [-b bfdname] kernel image
The mdsetimage command copies the disk image specified by image into the
memory disk storage area in kernel. The file system present in image
will typically be used by the kernel as the root file system.
To recognize kernel executable format, the -b flag specifies BFD name of
If the -s flags is given, mdsetimage will write back the actual disk
image size back into kernel.
If the -v flag is given, mdsetimage will print out status information as
it is copying the image.
If the -x flag is given, mdsetimage will extract the disk image from
kernel into the file image. This is the opposite of the default behav-
NetBSD 5.0 September 27, 2002 NetBSD 5.0