- NetBSD Manual Pages
IRFRAMETTY(4) NetBSD Kernel Interfaces Manual IRFRAMETTY(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
irframetty -- IrDA frame over serial line driver
The irframetty driver provides a tty(4) line discipline to send and
receive IrDA frames over a serial line via an IrDA dongle.
Access to the frames is via the irframe(4) driver.
Different dongles require different handling. The connected dongle type
can be set with ioctl(2) calls:
Set the dongle type. See the include file for possible dongles.
Get the dongle type.
Get the number of the irframe(4) device that must be used to
access the frames.
The irframetty driver appeared in NetBSD 1.6.
NetBSD 5.0 December 3, 2001 NetBSD 5.0