- NetBSD Manual Pages
VESAFB(4) NetBSD/i386 Kernel Interfaces Manual VESAFB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vesafb -- VESA framebuffer device driver for wscons
vesabios* at vesabiosbus?
vesafb* at vesabios?
wsdisplay* at vesafb? console ?
vesafb provides support for framebuffer consoles on i386 display adapters
which implement VESA BIOS extensions (VBE) 2.0 or above. It is used
within the wscons(4) console framework. And its functions are available
via the internal wsdisplay(4) interface.
Since this interface is accessed via x86 BIOS calls, this driver only
works on the i386 port.
Supported kernel options:
Required for vesabios. This enables the framework for running BIOS
code in a virtual 8086 machine.
Sets the width, such as 640 or 1024. Default is 640.
Sets the height, such as 480 or 768. Default is 480.
Sets the bits per pixel, such as 8 or 16. Default is 8.
Enables the power management support by enabling the
WSDISPLAYIO_SVIDEO and WSDISPLAYIO_GVIDEO ioctl implementations.
This is not enabled by default, as in some cases it might cause the
system to hang. Tested on: ATI Radeon M9 (failed), NeoMagic 256AV
(passed), VIA VT8623 (failed).
The vesafb driver appeared in NetBSD 4.0.
The vesafb driver attaches to the console very early in the i386 boot
process; since consinit() is called before KVM86 is initialized, the
vesafb_cnattach() function assumes that hardware is present. This causes
the console to be blank until the vesafb driver attaches.
vesafb does not support VBE 1.2 and below, as they do not provide support
for linear framebuffers.
options VESAFB_PM may cause some systems to hang.
NetBSD 5.0 August 16, 2006 NetBSD 5.0