rbox(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
RBOX(4)              NetBSD/hp300 Kernel Interfaces Manual             RBOX(4)


NAME
rbox -- HP98720 ``Renaissance'' graphics device interface
SYNOPSIS
rbox* at intio? rbox* at dio? scode ?
DESCRIPTION
This driver is for the HP98720 and 98721 graphics device, also known as the Renaissance. This driver has not been tested with all possible com- binations of frame buffer boards and scan boards installed in the device. The driver merely checks for the existence of the device and does minimal set up. The Renaissance can be configured at either the ``internal'' address (frame buffer address 0x200000, control register space address 0x560000) or at an external select code less than 32. At the internal address it will be the ``preferred'' console device. The hardware installation man- ual describes the procedure for setting these values. A user process communicates to the device initially by means of ioctl(2) calls. For the HP-UX ioctl(2) calls supported, refer to HP-UX manuals. The BSD calls supported are: GRFIOCGINFO Get Graphics Info Get info about device, setting the entries in the grfinfo struc- ture, as defined in <hpdev/grfioctl.h>. For the standard 98720, the number of planes should be 4. The number of colors would therefore be 15, excluding black. If one 98722A frame buffer board is installed, there will still be 4 planes, with the 4 planes on the colormap board becoming overlay planes. With each additional 98722 frame buffer board 4 planes will be added up to a maximum of 32 planes total. GRFIOCON Graphics On Turn graphics on by enabling CRT output. The screen will come on, displaying whatever is in the frame buffer, using whatever colormap is in place. GRFIOCOFF Graphics Off Turn graphics off by disabling output to the CRT. The frame buffer contents are not affected. GRFIOCMAP Map Device to user space Map in control registers and framebuffer space. Once the device file is mapped, the frame buffer structure is accessible. The structure describing the 98720 is defined in hpdev/grf_rbreg.h.
FILES
/dev/grf? BSD special file /dev/crt98720 /dev/ocrt98720 HP-UX starbase special files /dev/MAKEDEV.hpux script for creating HP-UX special files
EXAMPLES
This is a short segment of code showing how the device is opened and mapped into user process address space assuming that it is grf0: struct rboxfb *rbox; u_char *Addr, frame_buffer; struct grfinfo gi; int disp_fd; disp_fd = open("/dev/grf0",1); if (ioctl (disp_fd, GRFIOCGINFO, &gi) < 0) return -1; (void) ioctl (disp_fd, GRFIOCON, 0); Addr = (u_char *) 0; if (ioctl (disp_fd, GRFIOCMAP, &Addr) < 0) { (void) ioctl (disp_fd, GRFIOCOFF, 0); return -1; } rbox = (rboxfb *) Addr; /* Control Registers */ frame_buffer = (u_char *) Addr + gi.gd_regsize; /* Frame buffer memory */
DIAGNOSTICS
None under BSD. The HP-UX CE.utilities must be used.
ERRORS
[ENODEV] no such device. [EBUSY] Another process has the device open. [EINVAL] Invalid ioctl specification.
SEE ALSO
ioctl(2), grf(4), ite(4) For extensive code examples using the Renaissance, see the X device dependent source.
BUGS
Not tested for all configurations of scan board and frame buffer memory boards. NetBSD 5.0 September 10, 2001 NetBSD 5.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.