gbox(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
GB(4)                NetBSD/hp300 Kernel Interfaces Manual               GB(4)


NAME
gb -- HP98700 ``Gatorbox'' graphics device interface
DESCRIPTION
This driver is for the HP98700 and 98710 graphics devices, also known as the Gatorbox. The term ``Gator'' will often be used, and it is not to be confused with ``Gator'' used in reference to an HP 9837 or 200/237 machine. Also, the term Gatorbox is used for the 98700 alone, with the 98701 frame buffer memory or with the 98710 accelerator installed. This driver merely checks for the existence of the device and does minimal set up, as it is expected the applications will initialize the device to their requirements. The 98700 can be used as the only graphics device on a system, in which case it will be used as the system console. It can also be installed as a secondary display device. For the first case, the HP 98287A M.A.D. interface card should be set to internal control space. This will put the frame buffer at the DIO address 0x200000 and the control registers at 0x560000. At this address it will be the ``preferred'' console device (see cons(4)). For use as a secondary device, the 98287A should be set to frame buffer address 0x300000, and to an external select code. It should be noted that this configuration will conflict with the 98547 display card which has a 2 megabyte frame buffer starting at address 0x200000. The 98700 should only be installed as a secondary device in a machine with a 1 bit 98544 display card or 4 bit 98545 card. The 98700H Installation Guide contains further configuration information. The ioctl(2) calls supported by the BSD system for the Gatorbox are: GRFIOCGINFO Get Graphics Info Get info about device, setting the entries in the grfinfo struc- ture, as defined in <hpdev/grfioctl.h>. For the standard 98700, the number of planes should be 4. The number of colors would therefore be 15, excluding black. With the 98701 option installed there will be another 4 planes for a total of 8, giving 255 colors. GRFIOCON Graphics On Turn graphics on by enabling CRT output. The screen will come on, displaying whatever is in the frame buffer, using whatever colormap is in place. GRFIOCOFF Graphics Off Turn graphics off by disabling output to the CRT. The frame buffer contents are not affected. GRFIOCMAP Map Device to user space Map in control registers and framebuffer space. Once the device file is mapped, the frame buffer structure is accessible. The frame buffer structure describing the 98700 is given in <hpdev/grf_gbreg.h>. GRFIOCUNMAP Unmap Device Unmap control registers and framebuffer space. For further information about the use of ioctl see the man page.
FILES
/dev/grf? BSD special file /dev/crt98700 HP-UX starbase special file
EXAMPLES
A small example of opening, mapping and using the device is given below. For more examples of the details on the behavior of the device, see the device dependent source files for the X Window System, in the /usr/src/new/X/libhp.fb directory. struct gboxfb *gbox; u_char *Addr, frame_buffer; struct grfinfo gi; int disp_fd; disp_fd = open("/dev/grf0",1); if (ioctl (disp_fd, GRFIOCGINFO, &gi) < 0) return -1; (void) ioctl (disp_fd, GRFIOCON, 0); Addr = (u_char *) 0; if (ioctl (disp_fd, GRFIOCMAP, &Addr) < 0) { (void) ioctl (disp_fd, GRFIOCOFF, 0); return -1; } gbox = (gboxfb *) Addr; /* Control Registers */ frame_buffer = (u_char *) Addr + gi.gd_regsize; /* Frame buffer memory */
DIAGNOSTICS
None under BSD. HP-UX The CE.utilities/Crtadjust programs must be used.
ERRORS
[ENODEV] no such device. [EBUSY] Another process has the device open. [EINVAL] Invalid ioctl specification.
SEE ALSO
ioctl(2), grf(4) NetBSD 5.0 June 9, 1993 NetBSD 5.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.