- NetBSD Manual Pages
EDQUOTA(8) NetBSD System Manager's Manual EDQUOTA(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
edquota -- edit user quotas
edquota [-u] [-f filesystem] [-p proto-username] username ...
edquota -g [-f filesystem] [-p proto-groupname] groupname ...
edquota [-u] [-f filesystem] [-h block#/inode#] [-s block#/inode#]
edquota -g [-f filesystem] [-h block#/inode#] [-s block#/inode#]
edquota [-u] [-f filesystem] -t
edquota -g [-f filesystem] -t
edquota is a quota editor. By default, or if the -u flag is specified,
one or more users may be specified on the command line. Unless -h or -s
are used, a temporary file is created for each user with an ASCII repre-
sentation of the current disk quotas for that user. The list of filesys-
tems with user quotas is determined from /etc/fstab. By default, quota
for all quota-enabled filesystems are edited; the -f option can be used
to restrict it to a single filesystem. An editor is invoked on the ASCII
file. The editor invoked is vi(1) unless the environment variable EDITOR
The quotas may then be modified, new quotas added, etc. Setting a quota
to zero indicates that no quota should be imposed. Setting a hard limit
to one indicates that no allocations should be permitted. Setting a soft
limit to one with a hard limit of zero indicates that allocations should
be permitted on only a temporary basis (see -t below). The current usage
information in the file is for informational purposes; only the hard and
soft limits can be changed.
On leaving the editor, edquota reads the temporary file and modifies the
binary quota files to reflect the changes made.
If the -p flag is specified, edquota will duplicate the quotas of the
prototypical user specified for each user specified. This is the normal
mechanism used to initialize quotas for groups of users.
The -h and -s flags can be used to change quota limits (hard and soft,
respectively) without user interaction, for usage in e.g. batch scripts.
The arguments are the new block and inode number limit, separated by a
If the -g flag is specified, edquota is invoked to edit the quotas of one
or more groups specified on the command line. The -p flag can be speci-
fied in conjunction with the -g flag to specify a prototypical group to
be duplicated among the listed set of groups.
Users are permitted to exceed their soft limits for a grace period that
may be specified per filesystem. Once the grace period has expired, the
soft limit is enforced as a hard limit. The default grace period for a
filesystem is specified in /usr/include/ufs/ufs/quota.h. The -t flag can
be used to change the grace period. By default, or when invoked with the
-u flag, the grace period is set for all the filesystems with user quotas
specified in /etc/fstab. When invoked with the -g flag the grace period
is set for all the filesystems with group quotas specified in /etc/fstab.
The grace period may be specified in days, hours, minutes, or seconds.
Setting a grace period to zero indicates that the default grace period
should be imposed. Setting a grace period to one second indicates that
no grace period should be granted.
Only the super-user may edit quotas.
quota.user at the filesystem root with user quotas
quota.group at the filesystem root with group quotas
/etc/fstab to find filesystem names and locations
Various messages about inaccessible files; self-explanatory.
quota(1), quotactl(2), fstab(5), quotacheck(8), quotaon(8), repquota(8)
NetBSD 5.0 December 4, 2002 NetBSD 5.0