- NetBSD Manual Pages
DOSHUTDOWNHOOKS(9) NetBSD Kernel Developer's Manual DOSHUTDOWNHOOKS(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
doshutdownhooks -- run all shutdown hooks
The doshutdownhooks() function invokes all shutdown hooks established
using the shutdownhook_establish(9) function. Shutdown hooks are called
in reverse order, i.e., the shutdown hook established last will be called
This function is called from cpu_reboot() with interrupts turned off. It
is called immediately before the system is halted or rebooted, after file
systems have been unmounted, after the clock has been updated, and after
a system dump has been done (if necessary).
NetBSD 5.0 November 13, 1995 NetBSD 5.0