- NetBSD Manual Pages
CURPROC(9) NetBSD Kernel Developer's Manual CURPROC(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
curproc, curcpu -- current process and processor
struct cpu_info *
struct proc *
curcpu() returns a pointer to a cpu_info structure containing information
of the CPU that this thread is running on. curproc() returns a pointer
to the process currently running on this CPU.
NetBSD 5.0 May 23, 2002 NetBSD 5.0