- NetBSD Manual Pages
CPUCTL(8) NetBSD System Manager's Manual CPUCTL(8)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
cpuctl -- program to control CPUs
cpuctl command [arguments]
The cpuctl command can be used to control and inspect the state of CPUs
in the system.
The first argument, command, specifies the action to take. Valid com-
identify cpu Output information on the specified CPU's features and
capabilities. Not available on all architectures.
list For each CPU in the system, display the current state
and time of the last state change.
offline cpuno Set the specified CPU off line.
Unbound LWPs (lightweight processes) will not be exe-
cuted on the CPU while it is off line. Bound LWPs will
continue to be executed on the CPU, and device inter-
rupts routed to the CPU will continue to be handled. A
future release of the system may allow device interrupts
to be re-routed away from individual CPUs.
At least one CPU in the system must remain on line.
online cpuno Set the specified CPU on line, making it available to
run unbound LWPs.
/dev/cpuctl control device
The cpuctl command first appeared in NetBSD 5.0.
NetBSD 5.0 June 22, 2008 NetBSD 5.0