- NetBSD Manual Pages
CPU_CONFIGURE(9) NetBSD Kernel Developer's Manual CPU_CONFIGURE(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
cpu_configure -- machine-dependent device autoconfiguration
cpu_configure() is called during system bootstrap to perform the machine-
dependent portion of device autoconfiguration. It sets the configuration
machinery in motion by finding the root bus ("mainbus"). When this func-
tion returns, interrupts must be enabled.
cpu_configure() performs the following tasks:
· initialize soft interrupts (see softintr(9))
· initialize CPU interrupts and SPLs
· call config_rootfound() for "mainbus"
· complete any initialization deferred from cpu_startup().
NetBSD 5.0 May 23, 2002 NetBSD 5.0