- NetBSD Manual Pages
CHROOT(8) NetBSD System Manager's Manual CHROOT(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
chroot -- change root directory
chroot [-u user] [-g group] [-G group,group,...] newroot [command]
The chroot command changes its root directory to the supplied directory
newroot and exec's command, if supplied, or an interactive copy of your
If the -u, -g or -G options are given, the user, group and group list of
the process are set to these values after the chroot has taken place.
See setgid(2), setgroups(2), setuid(2), getgrnam(3) and getpwnam(3).
Note, command or the shell are run as your real-user-id.
The following environment variable is referenced by chroot:
SHELL If set, the string specified by SHELL is interpreted as the name
of the shell to exec. If the variable SHELL is not set, /bin/sh
chdir(2), chroot(2), environ(7)
The chroot utility first appeared in 4.4BSD.
chroot should never be installed setuid root, as it would then be possi-
ble to exploit the program to gain root privileges.
NetBSD 5.0 October 6, 1998 NetBSD 5.0