- NetBSD Manual Pages
APM(8) NetBSD System Manager's Manual APM(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
apm, zzz -- Advanced Power Management control program
apm [-abdlmsSvz] [-f sockname]
zzz [-Sz] [-f sockname]
apm communicates with the Advanced Power Management daemon, apmd(8), mak-
ing requests of it for current power status or to place the system into a
suspend or stand-by state. The apm tool is only installed on supported
With no flags, apm displays the current power management state in verbose
Available command-line flags are:
-z Put the system into suspend (deep sleep) mode.
-S Put the system into stand-by (light sleep) mode.
-l Display the estimated battery lifetime in percent.
-m Display the estimated battery lifetime in minutes.
-b Display the battery status. 0 means high, 1 means low, 2 means
critical, 3 means charging, 4 means absent, and 255 means
-a Display the external charger (A/C status). 0 means disconnected,
1 means connected, 2 means backup power source, and 255 means
-s Display if power management is enabled.
-v Request more verbose description of the displayed states.
Set the name of the socket via which to contact apmd(8) to
-d Do not communicate with the APM daemon; attempt instead to manip-
ulate the APM control device directly.
The zzz variant of this command is an alternative for suspending the sys-
tem. With no arguments, zzz places the system into suspend mode. The
command line flags serve the same purpose as for the apm variant of this
This command does not wait for positive confirmation that the requested
mode has been entered; to do so would mean the command does not return
until the system resumes from its sleep state.
/var/run/apmdev is the default UNIX-domain socket used for communication
with apmd(8). The -f flag may be used to specify an alternate socket
name. The protection modes on this socket govern which users may access
the APM functions.
/dev/apmctl is the control device which is used when the -d flag is spec-
ified; it must be writable for the -d flag to work successfully.
/dev/apm is the status device used when the socket is not accessible; it
must be readable to provide current APM status.
Advanced Power Management (APM) BIOS Interface Specification (revision
1.1), Intel Corporation and Microsoft Corporation
The apm command appeared in NetBSD 1.3.
NetBSD 5.0 June 18, 1996 NetBSD 5.0