uiomove(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
UIOMOVE(9)             NetBSD Kernel Developer's Manual             UIOMOVE(9)


NAME
uiomove -- move data described by a struct uio
SYNOPSIS
#include <sys/systm.h> int uiomove(void *buf, size_t n, struct uio *uio);
DESCRIPTION
The uiomove function copies up to n bytes between the kernel-space address pointed to by buf and the addresses described by uio, which may be in user-space or kernel-space. The uio argument is a pointer to a struct uio as defined by <sys/uio.h>: struct uio { struct iovec *uio_iov; /* pointer to array of iovecs */ int uio_iovcnt; /* number of iovecs in array */ off_t uio_offset; /* offset into file this uio corresponds to */ size_t uio_resid; /* residual i/o count */ enum uio_rw uio_rw; struct vmspace *uio_vmspace; }; A struct uio typically describes data in motion. Several of the fields described below reflect that expectation. uio_iov Pointer to array of struct iovecs: struct iovec { void *iov_base; /* Base address. */ size_t iov_len; /* Length. */ }; uio_iovcnt The number of iovecs in the array. uio_offset An offset into the corresponding object. uio_resid The amount of space described by the structure; notionally, the amount of data remaining to be transferred. uio_rw A flag indicating whether data should be read into the space (UIO_READ) or written from the space (UIO_WRITE). uio_vmspace A pointer to the address space which is being transferred to or from. The value of uio->uio_rw controls whether uiomove copies data from buf to uio or vice versa. The lesser of n or uio->uio_resid bytes are copied. uiomove changes fields of the structure pointed to by uio, such that uio->uio_resid is decremented by the amount of data moved, uio->uio_offset is incremented by the same amount, and the array of iovecs is adjusted to point that much farther into the region described. This allows multiple calls to uiomove to easily be used to fill or drain the region of data.
RETURN VALUES
uiomove returns 0 on success or EFAULT if a bad address is encountered.
SEE ALSO
copy(9), fetch(9), store(9) NetBSD 5.0.1 March 7, 2007 NetBSD 5.0.1
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.