- NetBSD Manual Pages
UCOM(4) NetBSD Kernel Interfaces Manual UCOM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ucom -- USB tty support
ucom* at ubsa?
ucom* at uchcom?
ucom* at uftdi?
ucom* at ugensa?
ucom* at uhmodem?
ucom* at uipaq?
ucom* at ukyopon?
ucom* at umct?
ucom* at umodem?
ucom* at uplcom?
ucom* at uslsa?
ucom* at uvisor? portno ?
ucom* at uvscom?
The ucom driver attaches to USB modems, serial ports, and other devices
that need to look like a tty. The ucom driver shows a behaviour like a
tty(4). This means that normal programs such as tip(1) or pppd(8) can be
used to access the device.
The portno locator can be used to decide which port to use for device
that have multiple external ports.
tty(4), ubsa(4), uchcom(4), uftdi(4), ugensa(4), uhmodem(4), uipaq(4),
ukyopon(4), umct(4), umodem(4), uplcom(4), usb(4), uslsa(4), uvisor(4),
The ucom driver appeared in NetBSD 1.5.
NetBSD 5.0.1 March 24, 2008 NetBSD 5.0.1