- NetBSD Manual Pages
RUMP_SYSPUFFS(8) NetBSD System Manager's Manual RUMP_SYSPUFFS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rump_syspuffs -- mount a puffs file server with a userspace puffs loop
rump_syspuffs file_server arguments
The rump_syspuffs utility can be used to mount any puffs(3) file server
so that the requests are passed through the kernel puffs code in
userspace as well. Therefore the approximate callgraph looks a little
like the following, where k and u denote code running in the kernel space
and userspace, respectively: puffs vfs (k) -> libpuffs (u) -> p2k (u) ->
puffs vfs (u) -> libpuffs (u) -> file server (u). The response path is
the same, but in reverse.
In its current state, rump_syspuffs is most useful as a proof of concept
for file system distribution and for developing and debugging the kernel
portion of puffs.
Mount a file system with sshfs:
rump_syspuffs mount_psshfs server.address /mnt
Mount an ntfs file system using ntfs-3g (from pkgsrc/filesystems/fuse-
ntfs-3g), set the default uid to 1323:
rump_syspuffs ntfs-3g -o uid=1323 /path/to/filesystem /mnt
p2k(3), puffs(3), rump(3) puffs(4)
The rump_syspuffs debugging utility first appeared in NetBSD 5.0.
NetBSD 5.0.1 August 9, 2008 NetBSD 5.0.1