- NetBSD Manual Pages
RUMP_NTFS(8) NetBSD System Manager's Manual RUMP_NTFS(8)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rump_ntfs -- mount the ntfs file system using a userspace server
rump_ntfs [options] special node
The rump_ntfs utility can be used to mount ntfs file systems. It uses
rump(3) and p2k(3) to facilitate running the file system as a server in
userspace. As opposed to mount_ntfs(8), rump_ntfs does not use file sys-
tem code within the kernel and therefore does not require kernel support
except puffs(4). Apart from a minor speed penalty (starting from 10% and
depending on the workload and file system in question), there is no dif-
ference to using in-kernel code.
In case mounting a file system image from a regular file, rump_ntfs does
not require the use of vnconfig(8) unlike kernel file systems. Instead,
the image path can be directly passed as the special file path. The
exception is if the image contains a disklabel. In this case vnconfig is
required to resolve the start offset for the correct partition within the
It is recommended that untrusted file system images be mounted with
rump_ntfs instead of mount_ntfs(8). Corrupt file system images commonly
cause the file system to crash the entire kernel, but with rump_ntfs only
the userspace server process will dump core.
To use rump_ntfs via mount(8), the flags -o rump and -t ntfs should be
given. Similarly, rump_ntfs is run instead of mount_ntfs(8) if ``rump''
is added to the options field of fstab(5).
Please see mount_ntfs(8) for a full description of the available command
p2k(3), puffs(3), rump(3), mount_ntfs(8)
The rump_ntfs utility first appeared in NetBSD 5.0. It is currently con-
NetBSD 5.0.1 February 15, 2009 NetBSD 5.0.1