- NetBSD Manual Pages
KNOTE(9) NetBSD Kernel Developer's Manual KNOTE(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
knote, KNOTE -- raise kernel event
knote(struct klist *list, long hint);
KNOTE(struct klist *list, long hint);
The knote() function provides a hook into the kqueue kernel event notifi-
cation mechanism to allow sections of the kernel to raise a kernel event
in the form of a `knote', which is a struct knote as defined in
knote() takes a singly linked list of knotes, along with a hint (which is
passed to the appropriate filter routine). knote() then walks the list
making calls to the filter routine for each knote. As each knote con-
tains a reference to the data structure that it is attached to, the fil-
ter may choose to examine the data structure in deciding whether an event
should be reported. The hint is used to pass in additional information,
which may not be present in the data structure that the filter examines.
If the filter decides that the event should be returned, it returns a
non-zero value and knote() links the knote onto the tail end of the
active list in the corresponding kqueue for the application to retrieve.
If the knote is already on the active list, no action is taken, but the
call to the filter occurs in order to provide an opportunity for the fil-
ter to record the activity.
knote() must not be called from interrupt contexts running at an inter-
rupt priority level higher than splsched().
KNOTE() is a macro that calls knote(list, hint) if list is not empty.
The knote() and KNOTE() functions first appeared in FreeBSD 4.1, and then
in NetBSD 2.0.
The kqueue() system was written by Jonathan Lemon <jlemon@FreeBSD.org>.
NetBSD 5.0.1 February 18, 2004 NetBSD 5.0.1