- NetBSD Manual Pages
FSCK_MSDOS(8) NetBSD System Manager's Manual FSCK_MSDOS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
fsck_msdos -- DOS/Windows (FAT) filesystem consistency checker
fsck_msdos -p [-f] filesystem ...
fsck_msdos [-fny] filesystem ...
The fsck_msdos utility verifies and repairs FAT filesystems (more com-
monly known as DOS filesystems).
The first form of fsck_msdos preens the specified filesystems. It is
normally started by fsck(8) run from /etc/rc during automatic reboot,
when a FAT filesystem is detected. When preening file systems,
fsck_msdos will fix common inconsistencies non-interactively. If more
serious problems are found, fsck_msdos does not try to fix them, indi-
cates that it was not successful, and exits.
The second form of fsck_msdos checks the specified file systems and tries
to repair all detected inconsistencies, requesting confirmation before
making any changes.
The options are as follows:
-f This option is ignored by fsck_msdos, and is present only
for compatibility with programs that check other file sys-
tem types for consistency, such as fsck_ffs(8).
-n Causes fsck_msdos to assume no as the answer to all opera-
tor questions, except ``CONTINUE?''.
-p Preen the specified filesystems.
-y Causes fsck_msdos to assume yes as the answer to all opera-
fsck(8), fsck_ffs(8), mount_msdos(8)
fsck_msdos is still under construction.
NetBSD 5.0.1 August 13, 1995 NetBSD 5.0.1