- NetBSD Manual Pages
DOPOWERHOOKS(9) NetBSD Kernel Developer's Manual DOPOWERHOOKS(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dopowerhooks -- run all power hooks
The dopowerhooks() function invokes all power hooks established using the
powerhook_establish(9) function. When power is disappearing the power
hooks are called in reverse order, i.e., the power hook established last
will be called first. When power is restored they are called normal
This function is called from the apm(4) driver when a power change is
NetBSD 5.0.1 December 3, 1999 NetBSD 5.0.1