- NetBSD Manual Pages
SHUTDOWN(8) NetBSD System Manager's Manual SHUTDOWN(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
shutdown -- close down the system at a given time
shutdown [-b bootstr] [-Ddfhknpr] time [message ... | -]
shutdown provides an automated shutdown procedure for super-users to
nicely notify users when the system is shutting down, saving them from
system administrators, hackers, and gurus, who would otherwise not bother
with such niceties.
The given bootstr is passed to reboot(8) for the benefit of
those systems that can pass boot arguments to the firmware.
Currently, this only affects sun3 and sparc machines.
-d shutdown will pass the -d flag to reboot(8) or halt(8). If nei-
ther the -h or -r flags are specified, then -d also implies -r.
-f shutdown arranges, in the manner of fastboot(8), for the file
systems not to be checked on reboot.
-h The system is halted at the specified time when shutdown execs
-k Kick everybody off. The -k option does not actually halt the
system, but leaves the system multi-user with logins disabled
(for all but super-user).
-n Prevent the normal sync(2) before stopping.
-p The system is powered down at the specified time when shutdown
execs halt(8). If the powerdown fails, or the system does not
support software powerdown, the system will simply halt.
-r The system is rebooted at the specified time when shutdown execs
-D Prevents shutdown from detaching from the tty with fork(2)/
time Time is the time at which shutdown will bring the system down
and may be the word now or a future time in one of two formats:
+number, or [[[[[cc]yy]mm]dd]hh]mm, where the century, year,
month, day, and hour may be defaulted to the current system val-
ues. The first form brings the system down number minutes from
the current time; the second brings the system down at the abso-
lute time specified. If the century is not specified, it
defaults to 1900 for years between 69 and 99, or 2000 for years
between 0 and 68. A leading zero in the ``yy'' value is not
Any other arguments comprise the warning message that is broad-
cast to users currently logged into the system.
- If - is supplied as the only argument after the time, the warn-
ing message is read from the standard input.
At intervals, becoming more frequent as apocalypse approaches and start-
ing at ten hours before shutdown, warning messages are displayed on the
terminals of all users logged in. Five minutes before shutdown, or imme-
diately if shutdown is in less than 5 minutes, logins are disabled by
creating /etc/nologin and copying the warning message there. If this
file exists when a user attempts to log in, login(1) prints its contents
and exits. The file is removed just before shutdown exits.
At shutdown time a message is written in the system log, containing the
time of shutdown, who initiated the shutdown and the reason. Next a mes-
sage is printed announcing the start of the system shutdown hooks. Then
the shutdown hooks in /etc/rc.shutdown are run. And a message is printed
indicating that they have completed. After a short delay a terminate
signal is then sent to init(8) to bring the system down to single-user
state (depending on above options). The time of the shutdown and the
warning message are placed in /etc/nologin and should be used to inform
the users about when the system will be back up and why it is going down
(or anything else).
/etc/nologin tells login(1) not to let anyone log in
/fastboot tells rc(8) not to run fsck when rebooting
/etc/rc.shutdown System shutdown commands
login(1), wall(1), fastboot(8), halt(8), reboot(8)
The hours and minutes in the second time format may be separated by a
colon (``:'') for backward compatibility.
The shutdown command appeared in 4.0BSD.
NetBSD 4.0 October 18, 2002 NetBSD 4.0