- NetBSD Manual Pages
NFSD(8) NetBSD System Manager's Manual NFSD(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
nfsd -- remote NFS server
nfsd [-6rut] [-n num_servers]
nfsd runs on a server machine to service NFS requests from client
machines. At least one nfsd must be running for a machine to operate as
Unless otherwise specified, four servers for UDP transport are started.
The following options are available:
-r Register the NFS service with rpcbind(8) without creating any
servers. This option can be used along with the -u or -t options
to re-register NFS if the portmap server is restarted.
-n Specifies how many servers to create.
-6 Listen to IPv6 requests as well as IPv4 requests. If IPv6 support
is not available, nfsd will silently continue and just use IPv4.
-t Serve TCP NFS clients.
-u Serve UDP NFS clients.
For example, ``nfsd -t -u -n 6'' serves UDP and TCP transports using six
A server should run enough daemons to handle the maximum level of concur-
rency from its clients, typically four to six. The maximum number of
daemon is 1024, the default is 4. If the number of servers on the com-
mand line exceeds 1024, it is reset to the default.
nfsd listens for service requests at the port indicated in the NFS server
specification; see Network File System Protocol Specification, RFC 1094
and NFS: Network File System Version 3 Protocol Specification.
The nfsd utility exits 0 on success, and >0 if an error occurs.
nfsstat(1), nfssvc(2), mountd(8), rpcbind(8)
The nfsd utility first appeared in 4.4BSD.
NetBSD 4.0 January 2, 2006 NetBSD 4.0