- NetBSD Manual Pages
MOUNT_TMPFS(8) NetBSD System Manager's Manual MOUNT_TMPFS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mount_tmpfs -- mount an efficient memory file system
mount_tmpfs [-g group] [-m mode] [-n nodes] [-o options] [-s size]
[-u user] tmpfs mount_point
The mount_tmpfs command attaches an instance of the efficient memory file
system to the global file system namespace. The directory specified by
mount_point is converted to an absolute path before use and its
attributes (owner, group and mode) are inherited unless explicitly over-
riden by the options described below.
The following options are supported:
-g group Specifies the group name or GID of the root inode of the file
system. Defaults to the mount point's GID.
-m mode Specifies the mode (in octal notation) of the root inode of
the file system. Defaults to the mount point's mode.
-n nodes Specifies the maximum number of nodes available to the file
-o options Options are specified with a -o flag followed by a comma-sep-
arated string of options. See the mount(8) man page for pos-
sible options and their meanings.
-s size Specifies the total file system size in bytes. If zero is
given (the default), the available amount of memory (includ-
ing main memory and swap space) will be used. Note that four
megabytes are always reserved for the system and cannot be
assigned to the file system.
-u user Specifies the user name or UID of the root inode of the file
system. Defaults to the mount point's UID.
Every option that accepts a numerical value as its argument can take a
trailing `b' to indicate bytes (the default), a trailing `k' to indicate
kilobytes, a trailing `M' to indicate megabytes or a trailing `G' to
indicate gigabytes. Note that both lowercase and uppercase forms of
these letters are allowed.
The following command mounts a tmpfs instance over the /tmp directory,
inheriting its owner, group and mode settings:
mount -t tmpfs tmpfs /tmp
The following command mounts a tmpfs instance over the /mnt directory,
setting a 20 megabytes limit in space, owned by the `joe' user and
belonging to the `users' group, with a restricted 0700 mode:
mount -t tmpfs -o -s20M -o -ujoe -o -gusers -o -m0700 tmpfs /mnt
See /usr/share/examples/fstab/fstab.ramdisk for some examples on how to
add tmpfs entries to /etc/fstab.
The mount_tmpfs utility first appeared in NetBSD 4.0.
NetBSD 4.0 November 11, 2006 NetBSD 4.0