- NetBSD Manual Pages
MAILER.CONF(5) NetBSD File Formats Manual MAILER.CONF(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mailer.conf -- configuration file for mailwrapper(8)
The file /etc/mailer.conf contains a series of lines of the form
name program [arguments ...]
The first word of each line is the name of a program invoking
mailwrapper(8). (For example, on a typical system /usr/sbin/sendmail
would be a symbolic link to mailwrapper(8), as would newaliases(1) and
mailq(1). Thus, name might be ``sendmail'' or ``newaliases'' etc.)
The second word of each line is the name of the program to actually exe-
cute when the first name is invoked.
The further arguments, if any, are passed to the program, followed by the
arguments mailwrapper(8) was called with.
The file may also contain comment lines, denoted by a `#' mark in the
first column of any line.
The default mailer is sendmail(8), which will also start by default
(unless specifically disabled via an rc.conf(5) setting) so that locally
generated mail can be delivered, if the ``sendmail'' setting in
/etc/mailer.conf is set to ``/usr/libexec/sendmail/sendmail''.
This example shows how to set up mailer.conf to invoke the traditional
# Execute the "real" sendmail program located in
This example shows how to invoke the postfix(1) MTA suite in place of
# Emulate sendmail using postfix
This example shows the use of the mini-sendmail package from pkgsrc in
place of sendmail(8): Note the use of additional arguments.
# Send outgoing mail to a smart relay using mini-sendmail
sendmail /usr/pkg/sbin/mini-sendmail -srelayhost
send-mail /usr/pkg/sbin/mini-sendmail -srelayhost
mail(1), mailq(1), newaliases(1), postfix(1), mailwrapper(8), sendmail(8)
mailer.conf appeared in NetBSD 1.4.
Perry E. Metzger <email@example.com>
The entire reason this program exists is a crock. Instead, a command for
how to submit mail should be standardized, and all the "behave differ-
ently if invoked with a different name" behavior of things like mailq(1)
should go away.
NetBSD 4.0 July 17, 2004 NetBSD 4.0