- NetBSD Manual Pages
ICP(4) NetBSD Kernel Interfaces Manual ICP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
icp -- ICP-Vortex and Intel Storage RAID driver
icp* at pci? dev ? function ?
ld* at icp? unit ?
icpsp* at icp? unit ?
scsibus* at icpsp?
The icp driver provides support for the newer (post 1997) ICP-Vortex GDT
and Intel Storage RAID controllers.
The ld driver provides access to logical devices (disk arrays) presented
by the controller. The icpsp driver provides direct access to other SCSI
devices attached to the controller, such as tape or CD-ROM drives.
pci_mem_find: expected mem type 00000000, found 00000002
This message may be displayed during autoconfiguration if
the controller's memory is mapped below 1MB in physical
address space. This can be disabled either through chang-
ing a setting in the controller's BIOS utility, or changing
the position of a jumper on the board. See your con-
troller's documentation for more information.
intro(4), ld(4), scsi(4)
The icp driver first appeared in NetBSD 1.6, and was based on the FreeBSD
and OpenBSD drivers of the same name.
ISA & EISA front-ends and a management interface are needed.
Older PCI boards are not yet supported.
NetBSD 4.0 April 20, 2002 NetBSD 4.0