- NetBSD Manual Pages
GEM(4) NetBSD Kernel Interfaces Manual GEM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
gem -- ERI/GEM/GMAC Ethernet device driver
gem* at pci? dev ? function ?
Configuration of PHYs may also be necessary. See mii(4).
The gem driver provides support for the GMac Ethernet hardware found
mostly in the last Apple PowerBooks G3s and most G4-based Apple hardware,
as well as many Sun UltraSPARCs.
Cards supported by this driver include:
· Sun GEM gigabit ethernet
· Sun ERI 10/100
· Apple GMAC
The GEM family supports hardware checksumming to assist in computing IPv4
TCP/UDP checksums. The gem driver supports this feature of the chip.
See ifconfig(8) for information on how to enable this feature.
bm(4), de(4), hme(4), mc(4), mii(4), tlp(4)
The gem device driver appeared in NetBSD 1.6.
The gem driver was written by Eduardo Horvath <eeh@NetBSD.org>. The man
page was written by Thomas Klausner <wiz@NetBSD.org>.
NetBSD 4.0 February 20, 2005 NetBSD 4.0