- NetBSD Manual Pages
ESL(4) NetBSD Kernel Interfaces Manual ESL(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
esl -- ESS Technology AudioDrive (Programmed I/O mode) family audio
esl* at pcmcia? function ?
audio* at audiobus?
opl* at esl?
The esl driver provides support for the ESS 1688 AudioDrive audio devices
on a PCMCIA card.
Since there is no way to do DMA over the PCMCIA bus, the esl driver uses
a Programmed I/O mode to drive the cards. This is very inefficient, but
is the only way to drive such a card.
Cards supported by this driver are capable of 8- and 16-bit audio sample
playback at rates up to 44.1kHz.
audio(4), midi(4), opl(4), pcmcia(4)
The esl device driver appeared in NetBSD 1.6.
Jared D. McNeill <email@example.com>
Putting a machine into suspend mode while this driver is active will
cause the machine to freeze.
Recording is not yet supported by this driver.
NetBSD 4.0 June 22, 2005 NetBSD 4.0