- NetBSD Manual Pages
DMESG(8) NetBSD System Manager's Manual DMESG(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dmesg -- display the system message buffer
dmesg [-M core] [-N system]
dmesg displays the contents of the system message buffer.
The options are as follows:
-M Extract values associated with the name list from the specified
core instead of the default ``/dev/mem''.
-N Extract the name list from the specified system instead of the
The system message buffer is a circular buffer of a fixed size. If the
buffer has been filled, the first line of the dmesg output may not be
complete. The size of the message buffer is configurable at compile-time
on most systems with the MSGBUFSIZE kernel option. Look for MSGBUFSIZE
in options(4) for details.
/var/run/dmesg.boot copy of dmesg at the time of last boot.
The dmesg command appeared in 4.0BSD.
NetBSD 4.0 April 30, 2004 NetBSD 4.0