- NetBSD Manual Pages
BOOT(8) NetBSD System Manager's Manual BOOT(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
boot -- system bootstrapping procedures
This document provides information on using common features in the NetBSD
In interactive mode, the boot loader will present a prompt, allowing
input of these commands:
boot [device:][filename] [-acdqsv]
The default device will be set to the disk that the boot loader
was loaded from. To boot from an alternate disk, the full name
of the device should be given at the prompt. device is of the
form xd [N[x]] where xd is the device from which to boot, N is
the unit number, and x is the partition letter.
The following list of supported devices may vary from installa-
tion to installation:
hd Hard disks.
fd Floppy drives.
The default filename is netbsd; if the boot loader fails to
successfully open that image, it then tries netbsd.gz (expected
to be a kernel image compressed by gzip), followed by
netbsd.old, netbsd.old.gz, onetbsd, and finally onetbsd.gz.
Alternate system images can be loaded by just specifying the
name of the image.
-a Prompt for the root file system device, the system crash
dump device, and the path to init(8).
-c Bring the system up into the device configuration manager.
From here the device locators can be tuned to the hard-
ware; see userconf(4).
-d Bring the system up in debug mode. Here it waits for a
kernel debugger connect; see ddb(4).
-q Boot the system in quiet mode.
-s Bring the system up in single-user mode.
-v Boot the system in verbose mode.
Immediately switch the console to the specified device dev and
reprint the banner. dev must be one of pc, com0, com1, com2,
com3, com0kbd, com1kbd, com2kbd, com3kbd, or auto. See Console
Selection Policy in boot_console(8).
Set the default drive and partition for subsequent filesystem
operations. Without an argument, print the current setting.
device is of the form specified in boot.
help Print an overview about commands and arguments.
Print a directory listing of path, containing inode number,
filename and file type. path can contain a device specifica-
quit Reboot the system.
In an emergency, the bootstrap methods described in the NetBSD installa-
tion notes for the specific architecture can be used.
/boot boot program code loaded by the primary boot-
/netbsd system code
/netbsd.gz gzip-compressed system code
/usr/mdec/boot master copy of the boot program (copy to /boot)
/usr/mdec/bootxx_fstype primary bootstrap for filesystem type fstype,
copied to the start of the netbsd partition by
ddb(4), userconf(4), boot_console(8), halt(8), installboot(8), reboot(8),
Any filename specified after the boot options, e.g.:
boot -d netbsd.test
is ignored, and the default kernel is booted.
NetBSD 4.0 November 25, 2006 NetBSD 4.0