core(5) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
CORE(5)                   NetBSD Programmer's Manual                   CORE(5)


NAME
core - memory image file format
SYNOPSIS
#include <sys/param.h>
DESCRIPTION
A small number of signals which cause abnormal termination of a process also cause a record of the process's in-core state to be written to disk for later examination by one of the available debuggers. (See sigaction(2).) This memory image is written to a file in the working di- rectory; provided the terminated process had write permission in the di- rectory, and provided the abnormality did not cause a system crash. (In this event, the decision to save the core file is arbitrary, see savecore(8).) The file is normally named programname.core, but is called core if the kernel configuration option options SHORTCORENAME is defined or the sysctl variable kern.shortcorename is set to 1. The maximum size of a programname.core file is limited by setrlimit(2). Files which would be larger than the limit are not created. The programname.core file consists of the u. area, whose size (in pages) is defined by the UPAGES manifest in the <sys/param.h> file. The u. area starts with a user structure as given in <sys/user.h>. The remainder of the programname.core file consists of the data pages followed by the stack pages of the process image. The amount of data space image in the programname.core file is given (in pages) by the variable u_dsize in the u. area. The amount of stack image in the core file is given (in pages) by the variable u_ssize in the u. area. The size of a ``page'' is given by the constant NBPG (also from <sys/param.h>).
SEE ALSO
gdb(1), sigaction(2), setrlimit(2)
HISTORY
A core file format appeared in Version 6 AT&T UNIX. NetBSD 1.4 December 11, 1993 1
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.