wskbd(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
WSKBD(4)                NetBSD Kernel Interfaces Manual               WSKBD(4)


NAME
wskbd -- generic keyboard support in wscons
SYNOPSIS
wskbd* at pckbd? console ? mux 1 (standard PC keyboard) wskbd* at ukbd? console ? mux 1 (USB keyboard) wskbd* at lkkbd? console ? mux 1 (DEC LK200/400 serial keyboard) wskbd0 at akbd? console ? mux 1 (Apple ADB keyboard) wskbd0 at nextkbd? console ? mux 1 (NeXT keyboard) wskbd* at vrkiu? console ? mux 1 (NEC VR4000 series HPC keyboard) wskbd* at skbd? console ? mux 1 (keyboard of misc hpcmips handheld devices) wskbd* at btkbd? console ? mux 1 (Bluetooth keyboard)
DESCRIPTION
The wskbd driver handles common tasks for keyboards within the wscons(4) framework. It is attached to the hardware specific keyboard drivers and provides their connection to ``wsdisplay'' devices and a character device interface. The common keyboard support consists of: · Mapping from keycodes (defined by the specific keyboard driver) to keysyms (hardware independent, defined in /usr/include/dev/wscons/wsksymdef.h). · Handling of ``compose'' sequences. Characters commonly not present as separate key on keyboards can be generated after either a special ``compose'' key is pressed or a ``dead accent'' character is used. · Certain translations, like turning an ``ALT'' modifier into an ``ESC'' prefix. · Automatic key repetition (``typematic''). · Parameter handling for ``keyboard bells''. · Generation of ``keyboard events'' for use by X servers. The wskbd driver provides a number of ioctl functions to control key maps and other parameters. These functions are accessible though the associ- ated ``wsdisplay'' device as well. A complete list is in /usr/include/dev/wscons/wsconsio.h. The wsconsctl(8) utility allows to access key maps and other variables. The console locator in the configuration line refers to the device's use as input part of the operating system console. A device specification containing a positive value here will only match if the device is in use as system console. (The console device selection in early system startup is not influenced.) This way, the console device can be connected to a known wskbd device instance. Keyboard encodings The following encodings are supported. Device drivers for legacy key- board interfaces may only support a subset of these. However, generally, all encodings are supported by pckbd(4) and ukbd(4). wsconsctl define language user KB_USER User-defined us KB_US English/US keyboard mapping (default) uk KB_UK English/UK keyboard mapping be KB_BE Belgian br KB_BR Brazilian with ``dead accents'' cf KB_CF Canadian French cz KB_CZ Czech (QWERTY) dk KB_DK Danish with ``dead accents'' nl KB_NL Dutch ee KB_EE Estonian with ``dead accents'' fi KB_FI Finnish fr KB_FR French de KB_DE German with ``dead accents'' gr KB_GR Greek hu KB_HU Hungarian is KB_IS Icelandic with ``dead accents'' it KB_IT Italian jp KB_JP Japanese la KB_LA Latin American Spanish no KB_NO Norwegian with ``dead accents'' pl KB_PL Polish pt KB_PT Portuguese ru KB_RU Russian es KB_ES Spanish sv KB_SV Swedish with ``dead accents'' sf KB_SF Swiss French sg KB_SG Swiss German tr KB_TR Turkish (QWERTY) with ``dead accents'' ua KB_UA Ukrainian us.declk KB_US|KB_DECLK English/US mapping for DEC LK400-style keyboards with PC keyboard interface (e.g., LK461) us.dvorak KB_US|KB_DVORAK English/US keyboard with ``Dvorak'' layout us.colemak KB_US|KB_COLEMAK English/US keyboard with ``Colemak'' layout KB_NODEAD ( ``.nodead'') can be applied to layouts with ``dead accents'' to switch them off. The KB_US, KB_UK, KB_FR, KB_JP and KB_US|KB_DVORAK mappings can be modi- fied to swap the left CTRL and the CAPS LOCK keys by the KB_SWAPCTRLCAPS variant bit or the ``.swapctrlcaps'' suffix. The KB_METAESC ( ``.metaesc'') option can be applied to any layout. If set, keys pressed together with the ALT modifier are prefixed by an ESC character. (Standard behaviour is to add 128 to the ASCII value.) Ioctls The following ioctl(2) calls are provided by the wskbd driver or by devices which use it. Their definitions are found in dev/wscons/wsconsio.h. WSKBDIO_GTYPE Get the keyboard type. WSKBDIO_COMPLEXBELL, WSKBDIO_SETBELL, WSKBDIO_GETBELL, WSKBDIO_SETDEFAULTBELL, WSKBDIO_GETDEFAULTBELL (struct wsmouse_repeat) Get and set keyboard bell settings. WSKBDIO_SETKEYREPEAT, WSKBDIO_GETKEYREPEAT, WSKBDIO_SETDEFAULTKEYREPEAT, WSKBDIO_GETDEFAULTKEYREPEAT (struct wskbd_keyrepeat_data) Get and set keyboard autorepeat settings. WSKBDIO_SETLEDS, WSKBDIO_GETLEDS (int) Get and set keyboard LED settings. WSKBDIO_GETMAP, WSKBDIO_SETMAP (struct wskbd_map_data) Get and set keyboard keymapping settings. WSKBDIO_GETENCODING, WSKBDIO_SETENCODING (kbd_t) Get and set keyboard encoding settings. WSKBDIO_GETKEYCLICK, WSKBDIO_SETKEYCLICK (int) Get and set keyboard keyclick settings. WSKBDIO_SETVERSION (int) Set the wscons_event protocol version. The default is 0 for binary compatibility. The latest version is always available as WSKBD_EVENT_VERSION, and is currently 1. All new code should use a call similar to the below to ensure the correct version is returned. int ver = WSKBD_EVENT_VERSION; if (ioctl(fd, WSKBDIO_SETVERSION, &ver) == -1) err(EXIT_FAILURE, "cannot set version");
FILES
/dev/wskbd* /usr/include/dev/wscons/wsksymdef.h /usr/include/dev/wscons/wsconsio.h.
SEE ALSO
btkbd(4), pckbd(4), ukbd(4), wscons(4), wsmux(4), wsconsctl(8), wskbd(9)
BUGS
The list of builtin mappings doesn't follow any logic. It grew as people submitted what they needed. NetBSD 9.3 July 13, 2020 NetBSD 9.3
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.