panic(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
PANIC(9)               NetBSD Kernel Developer's Manual               PANIC(9)


NAME
panic -- Bring down system on fatal error
SYNOPSIS
#include <sys/types.h> #include <sys/systm.h> void panic(const char *fmt, ...);
DESCRIPTION
The panic() function terminates the NetBSD system. The message fmt is a printf(3) style format string which is printed to the console and saved in the variable panicstr for later retrieval via core dump inspection. A newline character is added at the end automatically, and is thus not needed in the format string. If a kernel debugger is installed, control is passed to it after the mes- sage is printed. If the kernel debugger is ddb(4), control is only passed if the value of the ddb.onpanic sysctl(3) is ``1'', otherwise, a ddb(4)-specific function is used to print the kernel stack trace, and then control returns to panic(). If control remains in panic(), an attempt is made to save an image of system memory on the configured dump device. If during the process of handling the panic, panic() is called again (from the filesystem synchronization routines, for example), the system is rebooted immediately without synchronizing any filesystems.
RETURN VALUES
The panic() function does not return.
SEE ALSO
sysctl(3), ddb(4), ipkdb(4), options(4), savecore(8), swapctl(8), sysctl(8) NetBSD 3.0 September 27, 2002 NetBSD 3.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.