tcp(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
TCP(4)                  NetBSD Kernel Interfaces Manual                 TCP(4)


NAME
tcp - Internet Transmission Control Protocol
SYNOPSIS
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_STREAM, 0); int socket(AF_INET6, SOCK_STREAM, 0);
DESCRIPTION
The TCP provides reliable, flow-controlled, two-way transmission of data. It is a byte-stream protocol used to support the SOCK_STREAM abstraction. TCP uses the standard Internet address format and, in addition, provides a per-host collection of ``port addresses''. Thus, each address is com- posed of an Internet address specifying the host and network, with a spe- cific TCP port on the host identifying the peer entity. Sockets using TCP are either ``active'' or ``passive''. Active sockets initiate connections to passive sockets. By default TCP sockets are cre- ated active; to create a passive socket the listen(2) system call must be used after binding the socket with the bind(2) system call. Only passive sockets may use the accept(2) call to accept incoming connections. Only active sockets may use the connect(2) call to initiate connections. Passive sockets may ``underspecify'' their location to match incoming connection requests from multiple networks. This technique, termed ``wildcard addressing'', allows a single server to provide service to clients on multiple networks. To create a socket which listens on all networks, the Internet address INADDR_ANY must be bound. The TCP port may still be specified at this time; if the port is not specified the system will assign one. Once a connection has been established the socket's address is fixed by the peer entity's location. The address assigned the socket is the address associated with the network interface through which packets are being transmitted and received. Normally this address corresponds to the peer entity's network. TCP supports one socket option which is set with setsockopt(2) and tested with getsockopt(2). Under most circumstances, TCP sends data when it is presented; when outstanding data has not yet been acknowledged, it gath- ers small amounts of output to be sent in a single packet once an acknowledgement is received. For a small number of clients, such as win- dow systems that send a stream of mouse events which receive no replies, this packetization may cause significant delays. Therefore, TCP provides a boolean option, TCP_NODELAY (from <netinet/tcp.h>, to defeat this algo- rithm. The option level for the setsockopt(2) call is the protocol num- ber for TCP, available from getprotobyname(3). In the historical BSD TCP implementation, if the TCP_NODELAY option was set on a passive socket, the sockets returned by accept(2) erroneously did not have the TCP_NODELAY option set; the behavior was corrected to inherit TCP_NODELAY in NetBSD 1.6. Options at the IP network level may be used with TCP; see ip(4) or ip6(4). Incoming connection requests that are source-routed are noted, and the reverse source route is used in responding. There are many adjustable parameters that control various aspects of the NetBSD TCP behavior; these parameters are documented in sysctl(3), and they include: · RFC 1323 extensions for high performance · Send/receive buffer sizes · Default maximum segment size (MSS) · SYN cache parameters · Initial window size · Hughes/Touch/Heidemann Congestion Window Monitoring algorithm · Keepalive parameters · newReno algorithm for congestion control · Logging of connection refusals · RST packet rate limits
DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one; [ENOBUFS] when the system runs out of memory for an internal data structure; [ETIMEDOUT] when a connection was dropped due to excessive retrans- missions; [ECONNRESET] when the remote peer forces the connection to be closed; [ECONNREFUSED] when the remote peer actively refuses connection estab- lishment (usually because no process is listening to the port); [EADDRINUSE] when an attempt is made to create a socket with a port which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a net- work address for which no network interface exists.
SEE ALSO
getsockopt(2), socket(2), sysctl(3), inet(4), inet6(4), intro(4), ip(4), ip6(4) Transmission Control Protocol, RFC, 793, September 1981. Requirements for Internet Hosts -- Communication Layers, RFC, 1122, October 1989.
HISTORY
The tcp protocol stack appeared in 4.2BSD. NetBSD 2.0 November 23, 2003 NetBSD 2.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.