- NetBSD Manual Pages
VMX(4) NetBSD Kernel Interfaces Manual VMX(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vmx -- VMware VMXNET3 Virtual Interface Controller device
vmx* at pci? dev ? function ?
The vmx driver provides support for the VMXNET3 virtual NIC available in
virtual machines by VMware. It appears as a simple Ethernet device but
is actually a virtual network interface to the underlying host operating
This driver supports the VMXNET3 driver protocol, as an alternative to
the emulated pcn(4), wm(4) interfaces also available in the VMware envi-
ronment. The vmx driver is optimized for the virtual machine, it can
provide advanced capabilities depending on the underlying host operating
system and the physical network interface controller of the host. In
comparison to the earlier VMXNET versions, VMXNET3 supports additional
features like multiqueue support, IPv6 checksum offloading, MSI/MSI-X
support and hardware VLAN tagging in VMware's VLAN Guest Tagging (VGT)
The vmx driver supports VMXNET3 VMware virtual NICs provided by the vir-
tual machine hardware version 7 or newer, as provided by the following
· VMware ESX/ESXi 4.0 and newer
· VMware Server 2.0 and newer
· VMware Workstation 6.5 and newer
· VMware Fusion 2.0 and newer
The vmx driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
driver always uses the fastest available speed and the media
options provided by the underlying host of the virtual
10GbaseT mediaopt full-duplex
Set 10Gbps operation.
1000baseT mediaopt full-duplex
Set 1000Mbps operation.
For more information on configuring this device, see ifconfig(8).
The following entry must be added to the VMware configuration file to
provide the vmx device:
ethernet0.virtualDev = "vmxnet3"
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), pcn(4), wm(4),
The vmx device driver first appeared in OpenBSD 5.5 and was ported for
The vmx driver was originally written by Tsubai Masanari. NetBSD porting
was done by Hikaru ABE <hikaru@NetBSD.org>.
NetBSD 10.99 June 7, 2014 NetBSD 10.99