- NetBSD Manual Pages
VMT(4) NetBSD/x86 Kernel Interfaces Manual VMT(4)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vmt -- VMware Tools driver
vmt0 at cpu0
vmt0 at fdt?
The vmt driver is a kernel level implementation of VMware Tools. VMware
Tools are intended to provide better support for operating systems run-
ning inside virtual machines.
vmt handles shutdown, reboot, resume requests from the host by sending
events using sysmon_pswitch(9) of type PSWITCH_TYPE_POWER,
PSWITCH_TYPE_RESET, and PSWITCH_TYPE_SLEEP that can be handled by
powerd(8). vmt will log notifications that the guest has been suspended
or resumed by the host.
vmt reports the guest's hostname and first non-loopback IP address to the
The vmt driver synchronizes the virtual machine's clock with the host
clock in the following situations:
· When the virtual machine resumes after having been suspended.
· Periodically with the interval indicated by the
machdep.vmt0.clock_sync.period sysctl(8) variable. This is done so
that the virtual machine can keep its clock synchronized when the
host is suspended, because in this case the vmt driver receives no
notification of such an event. Setting this tunable to zero disables
The vmt driver first appeared in OpenBSD 4.4 and was then ported to
The vmt driver was written by David Gwynne <email@example.com>.
NetBSD 9.99 October 6, 2013 NetBSD 9.99